Read and Write NTFS in OS X El Capitan by installing ntfs-3g through Terminal


Too many users looking for free NTFS solution after upgrading to OS X 10.11 El Capitan. Right now, mac users can install ntfs-3g via Terminal to Read and Write NTFS in OS X 10.11. However, this solution is for the one do not access NTFS Volume frequently due to low data transferring speed and complicated to install.
#The weakness of NTFS-3G

  • Complicated installation
  • The read/write speed to NTFS partition is not optimized and similar to native HFS+
  • Limited to accessing to big number of files and large volume of Data
  • That does not support all Hard driver Brands leads to a very common “ntfs-3g could not mount” error
  • Unable to create, verify and repair NTFS partitions
  • Does not optimize the operations on SSDs.

At for paid professional NTFS software we would suggest Paragon NTFS 14 should be best NTFS driver for Mac due to it’s functionality and reasonable price (Paragon even offers 30 day money-back to guarantee their product’s quality). Go to Paragon NTFS Discount Page (coupon is added) to gain 25% OFF on purchase now.

NTFS-3G installation instruction

Firstly, launch Terminal.

  1. Install Homebrew:
    Use the following command to install Homebrew.

ruby -e “$(curl -fsSL”

  1. Then update Homebrew:

brew update

  1. Install Install Homebrew Cask:

brew install caskroom/cask/brew-cask

  1. Install osxfuse

brew cask install osxfuse

  1. Install ntfs-3g

brew install homebrew/fuse/ntfs-3g

Latest NTFS-3G can be downloaded from here.
In Mac OS X El Capitan, some NTFS Softwares can not be launched due to Rootless. What is Rootless? Find it your self. The point is how to disable Rootless?

sudo nvram boot-args=“rootless=0”

And then reboot.

Here is how to Create a symlink for mount_ntfs

sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.original
sudo ln -s /usr/local/sbin/mount_ntfs /sbin/mount_ntfs

If this solution either is so complicated or does not work, there is another software. Tuxera NTFS 2015 now support OS X 10.11 El Capitan fully. You can download Tuxera NTFS 2015 Full Version including license key from our another topic here.

Through Command Lines in Terminal, we absolutely can use awesome features in Mac OS X without using commercial softwares. You might want to took a look on Handle RAR and UNRAR through Command lines (Terminal) in Mac OS X without paying for archiver softwares.

Otherwise, Paragon NTFS 14.0.543 is Activated fully [FREE] by TNT is downloadable from this source.

Read at source: Download NTFS Driver for Mac & How to install NTFS-3G in Mac OS X.



This works on me.
Step 1: Install latest osxfuse which is compatible with El Capitan from Osxfuse.
Step 2: Install latest NTFS-3G from Homebrew
How to Install ntfs-3g? use the following command line:

brew install homebrew/fuse/ntfs-3g

Step 3: Link NTFS-3G to boot after temporary disabling rootless.

sudo nvram boot-args=“rootless=0”
sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.original
sudo ln -s /usr/local/sbin/mount_ntfs /sbin/mount_ntfs
sudo nvram boot-args=“rootless=1”

1 Like


These stuffs are like Linux code. I would rather to pay for the license bz It may take 2 hours to study about it :grin:



After 20 minutes, It works like a charm :kissing_smiling_eyes:



My problem is that my external device is still not able to be written on - I think it has to do with NTFS - there is shown I would use version of 2010 ?! - at least shown so in preferences in lower right corner and everything is disabled …



Look at this topic buddy:



Well in the meantime I got it running :wink:

1 Like

pinned globally #8


Hi, I got it working but now Finder does not show my usb drive even though it shows in /Volume

How do i get back my finder to detect my usb ntfs drive ?



its because of
sudo nano /etc/fstab
LABEL=DRIVE_NAME none ntfs rw,auto,nobrowse

the nobrowse cause it not to appear in finder.

ok anyway i remove the nobrowse, and now it appears but why cant i drag and copy into the usb ntfs drive still ??



Thanks Mr. Digger for the howto with ntfs-3g

However, it seems there is an issue in the osxfuse ver 2.8.2 (which is sourced via Homebrew Cask) causing the creation of a directory with the name of the partition label + an increment each time you mount it which is not deleted when unmount. Moreover, the partition is not shown in Finder

Details on the issue on github fourm (

Problem fixed in osxfuse ver 3.0+ thanks to bfleischer
Please download and install the latestet osxfuse dmg from here:

Works like a charm;)

Good luck!



sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.original
sudo ln -s /usr/local/sbin/mount_ntfs /sbin/mount_ntfs

for the above commands error is thrown for both, it says Operation not permitted. Why is that?
Haven’t been able to write to an NTFS external drive yet.



It seems that :
“sudo nvram boot-args=“rootless=0”

is not disabling the Filesystem Protection
Check the status of protection using “csrutil status” from the terminal command line
Should look like this:
System Integrity Protection status: enabled (Custom Configuration).
Apple Internal: disabled
Kext Signing: disabled
Filesystem Protections: disabled
Debugging Restrictions: disabled
DTrace Restrictions: disabled
NVRAM Protections: disabled

If it shows Filesystem Protections: enabled the follow the tutorial bellow to disable integrity protection:

I hope it helps



this free licence have here in the link at the bottom.



As I can see, with Tuxera NTFS copying files to my drive is much more and more faster!..
too bad I spent so time and disk space for Homebrew etc…



Agree, but Tuxera NTFS 2015 costs a lot of money. I do not access to NTFS drivers frequently. Whenever I plug the NTFS disk, I just use the following command lines to enable read/write NTFS to it. The administrator might be asked during the process.

sudo nano /etc/fstab


UUID=Universal Unique Identifier none ntfs rw

Universal Unique Identifier is determined by Disk Utility. For specific instruction, read at source.



operation permitted solution :
Reboot the Mac and hold down Command + R keys simultaneously after you hear the startup chime, this will boot OS X into Recovery Mode
When the “OS X Utilities” screen appears, pull down the ‘Utilities’ menu at the top of the screen instead, and choose “Terminal”
Type the following command into the terminal then hit return:
csrutil disable; reboot



operation not permitted solution.
Reboot the Mac and hold down Command + R keys simultaneously after you hear the startup chime, this will boot OS X into Recovery Mode
When the “OS X Utilities” screen appears, pull down the ‘Utilities’ menu at the top of the screen instead, and choose “Terminal”
Type the following command into the terminal then hit return:
csrutil disable

You’ll see a message saying that System Integrity Protection has been disabled and the Mac needs to restart for changes to take effect, and the Mac will then reboot itself automatically, just let it boot up as normal