Manually Enable Mac NTFS Write Support Using Terminal

Manually Enable Mac NTFS Write Support Using Terminal


This topic shows you how to enable NTFS Write support on a Mac for FREE by some steps. The following solutions works on All MacOS Versions: Mojave, High Sierra, Sierra, El Capitan, Yosemite, Mavericks, Snow Leopard, Leopard, and Lion.

Basically, what we need to do is adding the NTFS Drive name into the fstab file.

Step 1: Figure it out the NTFS Label name.
From Finder Window, find out and remember the NAME of the NTFS Volume (USB or External Disk) at the left side.
Step 2: Modify the fstab file

  • Launch Terminal (Found in Applications/Utilities), then enter the following command line.
sudo nano /etc/fstab
  • The fstab file then must be called in blank by default. You then enter the following command line.
LABEL=NAME none ntfs rw,auto,nobrowse

Note: The NAME must be replaced by your Drive name found in the step 1.
What to do if the Drive NAME contains words that are separated by a space? For example with MAC NTFS WRITE, the spaces will stand for “\040” (MAC\040NTFS\040WRITE).

  • Press exactly Ctrl + O to save and Ctrl + X to end the Terminal.

After the NTFS Drive is unmounted (you take it off), then plug it into the mac again in the next time, the Volume no longer exists at the left pane side any more. To find it, From Finder window, click on Go (on the top menu), then choose Go to Folder, then enter the /Volumes. The NTFS partition must appears then, and you are able to write the Data into it.
I hope all the above would help.

Mac NTFS Write – Possible Free Solutions

It works fine for me.
At the beginning, it didn’t worked because i wrote the name of my disk wrong (i just replaced space with \040) after that you do Ctrl + O, press Enter to save the modifications and then Ctrl + X to exit.
After that, my volume disapeared and it still didn’t work.
So i went back to the terminal and erased the content of the fstab and saved.
I reboot my system and my disk was back again.
I did the command line again (with the good spelling of my drive) and after i went to the utility disk application to unmount my drive and mount it again.
After that, I did a right click on the name of my drive and chose “Find it in the finder” (sorry don’t know if it’s the real name of this command because i’m french and it’s write in french for me :stuck_out_tongue: ).
I was then able to see my disk again and i put an shortcut on my desk and it was it !
Thank U, i tried hard to find a solution to this problem, U made my day !