Awesome trick to fix Dia Diagram Errors in Mac OS X Catalina, Mojave, High Sierra, Sierra, El Capitan, Yosemite,

Awesome trick to fix Dia Diagram Errors in Mac OS X Catalina, Mojave, High Sierra, Sierra, El Capitan, Yosemite,

Dia Diagram Editor is a useful and free tool to draw structured diagrams for both Mac OS X and Windows. Too many mac users prefer to use this tool because not only it is free under the terms of the GNU GNU General Public License, the GPLv2, but potentially also the valuable effectiveness in diagramming work.

However, many of users may not get it worked right away in Mac OS X Catalina, Mojave, High Sierra, Sierra and other MacOS X (10.11 El Capitan, 10.10 Yosemite, 10.9 Mavericks,…) due to facing some errors such as:

  • After installing Dia Diagram, the app is not be called and run. All is a x11 terminal windows, Dia does not start.
  • The domain/default pair of (.GlobalPreferences, AppleCollationOrder) does not exist error.
  • The error trace ended with GTK warning - could not open display.
  • And there should have more errors that I can not update all in this topic.

Whatever the errors are, look at the following trick to get rid of trouble.

  1. Right click on (found in /Applications), select Show Package Contents.
  2. Using a text editor to modify the dia file in
  3. What you need to do is add the following line after the line 39, then make sure you save your change and quit.

export DISPLAY=:0

  1. Close the XQuartz if this app is running, and then Dia Diagram should work smoothly in OS X without any errors (if not, you may attempt to restart your computer after the change).

Dear Digger,
Thanks for your info.

I´ve OS X El Capitan, downloaded the X11 and the dia installation file. I´m trying to following your steps but whenever I try to edit dia file in it gives me the info that the file is locked and cannot be edited.

Do you have any suggestion?

Thank you in advance,

Thank you very much for the solution. It worked perfectly for me.


You are most welcome buddy :slight_smile:

i have a issue with dia on osx.
Saved files generate a .dia file that when reopening is empty. The done drawing is not saved in the file somehow.
Does anybody encounter the same here?
Thanks, Regards

Thank you so much :slight_smile:

It worked. Thank you!

Thanks for such a helpful tips!

Much appreciated :slight_smile:

Worked for me. Thank you very much.

thanks very much! just did this to get Dia going on 10.14.4