iMessage not syncing between MacOS Mojave and iPhone


  • administrators

    How to fix if after upgrading to the new MacOS Mojave, iMessage not syncing between Mac and iPhone?

    • From Mac, Open “Messages app”
    • From the Top Menu, drop down the Message (next to the apple logo) > “Preferences” > “iMessages” > Enable “Messages in iCloud”
      0_1542606420410_fix-iMessage-not-syncing-between-MacOS-Mojave-and-iPhone.jpg

    Lastly, Go to the “Setting app” on iPhone > “Profile Name” > “iCloud” > “Turn on Toggle” for Messages.